Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Soundfont doesn’t play sound on lower velocities

Soundfont doesn’t play sound on lower velocities 2 months 2 weeks ago #1

  • someone45357
  • someone45357's Avatar
  • Offline
  • New Member
  • Posts: 9
I made a piano soundfont that has 4 different variations of each note so I applied each one to play at a different velocity, but for some reason when I do it now at a certain velocity no sound will play (anything below 70 for some reason). And that’s sort of whats bugging me since I know it can’t be that its because I binded the variations to different velocities since the first and second repeat for velocities 80-89 and 70-79 but everything else does nothing for some reason.

I can send in the soundfont if youd like to see more in depth what im talking about
The administrator has disabled public write access.

Soundfont doesn’t play sound on lower velocities 2 months 2 weeks ago #2

  • bottrop
  • bottrop's Avatar
  • Offline
  • Elite Member
  • Posts: 259
  • Thank you received: 50
yes, its hard to say anything without seeing the parameters, so if you can drop it somewhere i will have a look.
regards bottrop
The administrator has disabled public write access.

Soundfont doesn’t play sound on lower velocities 2 months 2 weeks ago #3

  • someone45357
  • someone45357's Avatar
  • Offline
  • New Member
  • Posts: 9
Here it is, its slightly bigger than the file limit so thats why its in this link

ufile.io/1nwjxuzh
The administrator has disabled public write access.

Soundfont doesn’t play sound on lower velocities 2 months 1 week ago #4

  • bottrop
  • bottrop's Avatar
  • Offline
  • Elite Member
  • Posts: 259
  • Thank you received: 50
your soundfont plays in the low Velocities, but very very low, so it is just a matter of raising the volume of your amplifier. i boosted the Volume a little, maybe you will have to Attenuate the higher Velocity layers (in the Instrument view).
to be frank, i dont understand the structure of your soundfont, maybe you want to achieve an roundrobin effect?
i rebuilt it in mono, since your left and right channel samples are exactly the same (waste of memory). though it is nonsense to create stereo instruments, if you believe in that, you can add another 13 instruments to the Preset and pan the lot.

your Sample names are too long and are truncated so they dont give the full information anymore.

drive.google.com/file/d/1iC4SuhKjLuN6DOS.../view?usp=drive_link
The administrator has disabled public write access.

Soundfont doesn’t play sound on lower velocities 2 months 1 week ago #5

  • someone45357
  • someone45357's Avatar
  • Offline
  • New Member
  • Posts: 9
Well I’m not sure about the whole mono and stereo thing to begin with, I only had kept it through all my sounds fonts because I believed not having it would compromise the quality output of the sound since it might only come out of one speaker, and for the music I make that could be very compromising to it if it worked like that so I never tried to go against it.

And I’m not sure also why then the volume is working so low on the lower velocities to the point where you cant even hear it, I also don’t exactly know how attenuation works in of in itself so I’m not sure how I could fix this. Would normalizing the samples themselves do anything?

Also yes I wanted the soundfont to have sort of dynamic layers/round robins hence why it has different samples set to different velocities. My daw plays velocities not necessarily all that consistently so it makes it actually feel like its playing round robins depending on how much I key it. The naming is all messed up (aka basically the same with code numbers) in the final product on purpose because it makes it a lot easier to copy paste each “round robin” on one another to make the instruments to put in the preset, reducing the otherwise very tedious process that it involves. It’s especially helpful when I want to put like 8-10 to just have to copy paste replace the samples for each one of those.

Edit: ok I just tested the soundfont you sent and it seems to actually be doing worse. Now only the highest velocities play with actual volume unlike before where at least it was like that until it got to velocity 70. I’m so confused as to why this is even happening
Last Edit: 2 months 1 week ago by someone45357. Reason: I just found out about some crucial info regarding the matter
The administrator has disabled public write access.

Soundfont doesn’t play sound on lower velocities 2 months 1 week ago #6

  • bottrop
  • bottrop's Avatar
  • Offline
  • Elite Member
  • Posts: 259
  • Thank you received: 50
it is happening because according to the soundfont protocol notes at low velocity play softer than notes at high velocity.
at a lower Velocity in soundfonts a sample plays in a lower Volume and a little longer Attack. you cant use Velocity for two purposes at a time.
i cant hear much Dynamic difference in your sample sets and if there was, it would be nonsense to use set 1 for the 0-09, 40-49, 80-89 and 120-127 velocity layers.
regards bottrop
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.052 seconds
indian porn movies free download indian sex xxx tube com www xxxx porn video